CHAPTER 3

Spatial data input
Analysis and modeling in a GIS requires input of relevant data. The data consist of
two types: spatial data representing geographic features (points, lines and areas)
and attribute data (descriptive information). Data input should be done with utmost
care, as the results of analyses heavily depend on the quality of the input data. In
ILWIS data can be entered by:
−

Digitizing, if you want to use data from analog (paper) maps;

−

Keyboard entry, for entering tabular data;

−

Scanning, if you want to use paper prints of satellite images, aerial
photographs, maps and pictures;

−

Importing existing data files from other sources.

This chapter explains how to digitize maps. The next chapter deals with the import
of digital map data, and in chapter 5 the import and creation of tables is treated.
Before you can start with the exercises, you should start up ILWIS and change to
the subdirectory c:\ilwis21\data\usrguide\chap03, where the data files for this
chapter are stored.
Apart from a segment map used in exercise 3.5, you will create all digital data for
this chapter yourself.

F
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•

Double-click the ILWIS program icon in the ILWIS program group.

•

Change the working drive and the working directory until you are in
the directory c:\ilwis21\data\usrguide\chap03.
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Digitizing
The most common method of entering spatial data in ILWIS is digitizing. Features
on a paper map or other analog documents (e.g. a photo-interpretation on a piece of
tracing film) can be digitized. This can be done using a device called a digitizing
tablet, or digitizing table, or simply digitizer. A digitizer contains a pointing device
(digitizer cursor) to trace spatial features. The position of the digitizer cursor is
registered electronically to a precision of fractions of a millimeter. This is done
through a fine grid of wires embedded in the digitizer (figure 3.1).
The vertical wires record the X-coordinates; the horizontal ones the Y-coordinates.
The range of digitizer coordinates depends, amongst other thing, on the density of
the network of wires: digitizer resolution. The cursor contains a small transparent
window with a cross-hair, and a number of buttons (at least four buttons are needed
to work with ILWIS). When you press one of the buttons, an electromagnetic signal
is transmitted and the position of the cross-hair is recorded by one of the horizontal
and one of the vertical wires. From it a coordinate pair, in digitizer units, is defined
and sent to the computer.
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Y
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X
Figure 3.1: Operation of a digitizer (simplified)
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3.1 Map referencing
A digitizer records the location of spatial features by means of digitizer
coordinates. To correctly register features in a map, the relationship between map
and digitizer coordinates needs to be established. A minimum of three control
points and the corresponding map coordinates, should be specified by the user in
order to calculate the transformations between digitizer and map coordinates. Since
both coordinate systems are metric, an affine transformation is used.
With the map coordinates of the control points expressed as Xi,Yi and the
digitizer coordinates as Xdig,i, Ydig,i (figure 3.2), the following formula for
an affine transformation is used to calculate the transformation coefficients:
Xi = a1,1 * Xdig,i
Yi = a2,1 * Xdig,i

+
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ai,j and bi are the affine transformation coefficients.
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Figure 3.2: Referencing a map to a digitizer (simplified). Left: the digitizer contains an active area.
Only within that area, the horizontal and vertical wires inside the digitizer can pick up a
signal from the digitizer cursor (right)

To determine the six transformation coefficients, at least three coordinate pairs are
required. If three or more coordinate pairs are entered, the equations are complete
and the coefficients are calculated. Using the affine transformation, new sets of
coordinate pairs are calculated for the control points. The differences between the
actual and the calculated coordinates of the control points (the residuals), indicate
how well the control points have been digitized and entered. Errors in location or
typing result in large residuals.
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Creating a coordinate system
Before you can start digitizing, you should first pay attention to the coordinate
system in which you will digitize your map. You may for instance use user-defined
coordinates, coordinates defined by a national standard or coordinates of a certain
UTM zone. The information on the coordinates of the maps you use in a project, is
stored in a coordinate system. A coordinate system defines the possible minimum
and maximum X's and Y's that can be used in a map, along with other information
on map datum, projection etc., as was mentioned in the previous chapter. A map
projection defines the relationship between the map coordinates and the geographic
coordinates latitude and longitude.
ILWIS has two standard coordinate systems:
−

Latlon: Geographical coordinates in degrees

−

Unknown: This is the coordinate system you can use if you do not want to
specify the projection used in your maps. In that case you define your own local
coordinate system; only the minimum and maximum X and Y values are stored
and there is no need for projection parameters.

In most situations, however, it is better to generate a new coordinate system for the
area where you are working, especially when the dataset that you prepare is
intended to be used for a longer period, and may have to be combined with maps
from other sources, which may be in another projection.
In principle, all the maps that are used of a certain area should have the same
coordinate system. ILWIS expects that all maps that you want to superimpose or
display together in one map window have the same coordinate system. Therefore,
when you start with a project you first create a coordinate system, and you use this
for all the maps which you digitize or that you import from other sources.
It may be so that you do not know the map projection of the map that you are going
to digitize. In that case you cannot fill in the projection parameters in the
coordinate system, and therefore, you don’t know the relationship between metric
and geographic coordinates. This is not a problem as long as you don’t want to
combine your data with maps in other projections.
We strongly advise you not to digitize your map in a coordinate system that you
invent yourself, for example just by taking the lower left corner of the map as X=0
and Y=0. If you do so it will be very difficult to combine your own digitized data
with that from other sources. Each topographic map should contain information on
the map projection that was used. For example, on the topomap of Cochabamba, the
following information is given:
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−

Ellipsoid: International.

−

Projection: Transverse Mercator.

−

Vertical Datum: Sea level.

−

Horizontal datum: Provisional South America 1956.

−

UTM zone: 19 K.
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In the next chapter there will be more explanation on map projections, and
especially about UTM.
The map that you are going to digitize first, is shown in figure 3.3. As you can see
from that map the actual study area is located between the following coordinates
(which are in UTM zone 19):
−

minimum X = 795000

−

maximum X = 808500

−

minimum Y = 8071500

−

maximum Y = 8090500

Now that you know the coordinate boundaries of your map and the projection
information, you can generate the coordinate system that will be used for all maps
of the Cochabamba area.

!

Note that if you want to extend your study area and digitize adjacent areas you
need to extend the range of coordinates as defined in the coordinate system.

F
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•

Double-click the New CrdSys item in the Operations-list. The
Create CoordSystem dialog box is opened.

•

Type for the Coordinate System Name: Cochabam.

•

Type for the Description: Coordinate system of
Cochabamba in UTM.

•

Click OK. The Edit Coordinate System dialog box is opened.

•

Press the Projection button and select the projection UTM. Click
OK.

•

Click the Ellipsoid button, and select the ellipsoid:
International 1924. Click OK.

•

Click the Datum button and select the datum: Provisional
South American 1956 and select the Area: Bolivia. Click
OK.

•

Clear the check box Northern Hemisphere.

•

Enter for the UTM zone: 19

•

Type for Min X: 795000,Type for Min Y: 8071500

•

Type for Max X: 808500,Type for Max Y: 8090500

•

Click OK in the Edit Coordinate System dialog box.
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The coordinate system Cochabam is now created and you can proceed with the
referencing of your map.
Referencing a map to the digitizer

!

Before starting map referencing check whether the digitizer setting is correct.
This can be done by opening the Options menu in the main window and select
Digitizer, Setup Digitizer (see the ILWIS Installation Guide for a detailed
description on how to set-up your digitizer).

To digitize a map, the coordinate system of the map must be referenced to that of
the digitizer. In this exercise the point map shown in figure 3.3 will be referenced.

F
•

Make a photocopy of figure 3.3.

•

Position this map in the center of your digitizer and fasten it to the
digitizer with tape. With some digitizers you can also place the paper
under a plastic cover, so that it remains fixed.

•

From the Options menu of the main window, select Digitizer.

•

Choose Map Reference from the sub-menu.

The Map Referencing dialog box is opened. In this box you can select or create a
coordinate system, in which minimum and maximum X and Y coordinates of the
map are defined, as well as the map projection. The information is used to describe
how coordinates on the earth surface are related to corresponding coordinates on
the map.
The option buttons in the dialog box are used to select metric or geographic
coordinates. Note, if you choose geographic coordinates, a projection and
associated parameters have to be defined. The information is needed for
transformation of geographic coordinates to metric ones.

!

You can use the Transform Coordinates operation, to check whether the
transformation from metric to geographic coordinate system and vice versa are
correct (see also chapter 4, exercise: Map projections).

F
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•

Select Cochabam in the list box Coordinate System.

•

Accept the defaults by clicking the OK button.
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Figure 3.3: Point map Mountop
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The Map Referencing dialog box (figure 3.4) and MapReferencing command
box (figure 3.4) are opened. The Map Referencing command box shows the
coordinates of the digitizer cursor location and contains the options: Digitize Point,
Next Point and Delete Point. The numbers (0, 1, 2, 3,) refer to the digitizer
cursor buttons which are normally labeled 0, 1, 2, 3, or 1, 2, 3, 4, or A, B, C, D.
The commands in this window are used for digitizing control points and have the
following meaning:
−

Button 0: Digitizes a control point on the map.

−

Button 1: Moves to the next control point.

−

Button 2: Deletes the currently active control point.

F
•

!

Move your digitizer cursor over the digitizing table. When you do so
you should see the coordinates change in the upper part of the Map
Referencing command box.

When you don’t see any coordinates in the Map Referencing command box,
or when the coordinates remain the same while you move the digitizer cursor
over the digitizer, your digitizer is not set-up properly. Check the digitizer
installation (See ILWIS Installation Guide).

Digitizing control points

F
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•

Position the digitizer cursor at point A of the map and press the 0
button.

•

Type 795000 for the X coordinate (left) and 8071500 for the Y
coordinate (right) of the point.

•

Position the digitizer cursor to point B and press the 0 button.

•

Type 808500 for the X coordinate and 8071500 for the Y
coordinate of the point.

•

Move the digitizer cursor to point C and press the 0 button.

•

Type 808500 for the X coordinate and 8090500 for the Y
coordinate of the point.

•

Move the digitizer cursor to point D and press the 0 button.

•

Type 795000 for the X coordinate and 8090500 for the Y
coordinate of the point.
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Figure 3.4: The Map Reference dialog box and the Map Reference command box (upper left). The
actual values displayed on your computer may be different from the ones shown in the
figure, depending on the type of digitizer you used, the precision (lines per inch), and
the accuracy with which you digitized the four points

The Map Referencing dialog box shows information such as:
−

Digitizer: The digitizer coordinates in millimeters.

−

Text boxes Coordinates: The real world X and Y coordinates (metric or
geographic, depending on what you selected in the first Map Reference
dialog box; in this case metric).

−

diff X diff Y: The diff X and diff Y columns indicate deviations (in
millimeters) between the actual map coordinates and the calculated ones. A
large deviation may signify that the coordinate pairs were entered incorrectly.
If less than three points have been digitized, diff X and diff Y are 0 since no
deviation can be calculated.

−

Sigma: The value of Sigma (in millimeters) for the current data, indicates the
accuracy with which the control points have been digitized. If the value of
sigma is much larger than 1, this indicates that an error was made when
digitizing the points, or when entering the coordinates. Sigma is the standard
deviation calculated from the differences between the digitized and the
calculated control points.
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−

Scale: The calculated scale in horizontal and vertical or X and Y axes assumes
that the entered coordinates are metric. It also takes into account the resolution
of the digitizer (lines/mm or lines/inch as specified in the digitizer
configuration).

−

Rotation: The rotation of the map coordinates (X and Y axes) relative to the
digitizer X and Y axes.

−

Option buttons transformation: The formulas used to calculate the
transformation between digitizer and real world coordinates. Affine
transformation is a first order function requiring a minimum of three tiepoints. The order of this transformation is sufficient to account for changes in
scale on the X and Y axes and for the map translation and rotation. The
Conformal transformation is also a first order function but needs a minimum of
two tie-points. By selecting the Conformal transformation, the program only
accounts for scale differences in X and Y axes and for map rotation. Although
mathematically two or three tie-points are needed for the conformal or affine
transformations, it is preferred to use at least four tie-points to derive a notion
of accuracy.

F

!

•

Accept the default (Affine transformation).

•

If the sigma is less than 1, click the OK button.

•

If the sigma is larger than 1, repeat entering the tie-points until the
sigma is less than 1 and then click the OK button.

When you digitize paper maps that are quite old, or that have been exposed to
sunlight, the paper may not contain the same scale in X and Y direction, due to
shrinking. In such a case you will also not reach a sigma that is around 1, and
you either have to get a better paper copy to digitize, or accept that it is less
accurate.
When producing a map from image interpretation that is to be used for
digitizing, it is therefore recommended, not to use paper, but a transparent film
type that will not shrink.

The digitizer is referenced to the map. The map reference setting is stored and will
remain unchanged until you enter a new reference setting. If the position of the
map on the digitizer has changed, or if you start to digitize another map, it is
necessary to reference the map again.
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Summary: Map referencing
−

A digitizer records the coordinates of spatial features by means of digitizer
coordinates. The relationship between the map and digitizer coordinate is
established by referencing the coordinates of the map to that of the digitizer.

−

A minimum of three control points and the corresponding map coordinates are
required to reference the map. The map reference settings are stored and will
remain unchanged until you enter new reference settings.
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3.2 Digitizing a point map
In this exercise a point map called Mountop will be created. The points in the map
show the peaks of mountains and hills in the Cochabamba area, Bolivia. A hardcopy of the map is presented in figure 3.3. A photocopy of the same map was used
in the previous exercise for map referencing.

!

It is assumed that the photocopy of figure 3.3 is still attached in the same
position on your digitizer table. If you removed the map, you will have to
repeat the map referencing (explained in the previous exercise), since the
position of the control points on the digitizer may have changed.

F
•

Double-click New PntMap in the Operations-list in the Main
window. The Create Point Map dialog box is opened.

•

Type Mountop in the Map Name text box.

•

Type for the Description: Points indicating mountain
tops.

•

Select the Coordinate system: Cochabam. This is the coordinate
system that you have created in the previous exercise. Note that the
display of the minimum and maximum X and Y coordinates changes,
as the values of the coordinate system are used.

•

Click the Create button next to the Domain list box. The Create
Domain dialog box is opened.

As explained in the previous chapter, service objects such as a Domain and a
Coordinate System, are needed to create a map (data object). A list of IDs or
classes, or the value ranges and the precision used to codify elements in a map, are
defined in a Domain. The domain contains all possible names or values that may
occur in a map. See also chapter 2 for more information about domains.

F
•

Type Mountop in the text box Domain Name.

•

Select the option Identifier.

The domain type Identifier (ID) is selected for this point map, because each point in
the map is identified by a unique number. Selecting the domain type Identifier, a
text box with the default value 0 appears. Optionally, you can use the text box to
define the number of items in the domain. It is also possible to give each item a
prefix (e.g. nr, or point).
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F
•

Accept the default for the Number of Items (0) and click OK.

The Domain Editor is opened. The editor can be used to add, change or delete
items in the domain. When you digitize you can either:
−

First describe all domain items before you digitize, or;

−

Define the domain items while you digitize.

The point IDs will be entered during digitizing.

F
•

Close the Domain Editor. You are now back in the Create Point
Map dialog box. Note that the domain Mountop, which you just
created, is indicated in the list box Domain.

•

Click OK in the Create Point Map dialog box. The Display
Options - Points dialog box is opened.

•

Accept the defaults by clicking the OK button in this dialog box.

The Point Editor and the Point Editor command box are opened (figure 3.5).

Figure 3.5: The Point Editor map window and the Point Editor command box
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The Point Editor command box shows the position of the digitizer cursor and
consists of the following commands:
−

Button 0: Add point: For digitizing a new point.

−

Button 1: Move point: Allows you to move a point.

−

Button 2: Change window: For changing the window displayed on the
screen.

−

Button 3: Edit point: For editing the label of a point.

The following buttons on the button bar of an ILWIS Editor window are shortcuts
to select different modes and to exit the Editor:

Select Mode: this allows selection of one or more existing features
(points, segments, polygons or pixels) in the Editor. When you click the
Select Mode button the mouse cursor appears as a little hand. In this
mode you can select a feature by clicking it.

Move Point Mode: this allows you to select a point (or a point within a
segment) and drag it to a new position. When you click the Move Point
Mode button, the mouse pointer appears as a pair of little tweezers.

Insert Mode: this allows you to insert new features. When in the Insert
Mode, the mouse cursor appears like a little pencil.

Exit the Editor: used to exit the Editor.
The Point Editor works in the Select, Move Point and Insert Modes.
Digitizing points

F
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•

Position the digitizer cursor at point 1 and press button 0 (Add
point).

•

A small box is opened at the digitized point. Type p1 in this box and
press Enter.

•

Digitize the rest of the points (figure 3.3) and label them as follows:
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Table 3.1: The codes used for digitizing the points in figure 3.3
Point #
1
2
3
4
5

Point label
p1
p2
p3
p4
p5

Point #
6
7
8
9
10

Point label
p6
p7
p8
p9
p10

Point #
11
12
13
14
15

Point label
p11
p12
p13
p14
p14

When you enter the label p14 for the point 15, the Point Editor message box is
opened indicating that the label p14 is used for another point. Although the
Identifier domain allows for duplicate names, it is not very logical to have two
points in an ID domain with the same name. To enter the correct label for this
point:

F
•

Select No from this box and enter a new name for this point.

•

Type p15 and Enter.

Editing a point
The label (ID) of a point can be edited or changed if incorrectly entered. To edit or
change the label of a point:

F
•

Position the digitizer cursor at the point which has to be edited, in
this case point 15 and press button 3. Type a new label for this point,
e.g., p16 and Enter.

•

Position the digitizer cursor at the point which has to be moved, in
this case point 14 and press button 1.

Moving a point

F

The Move Point command box is shown (figure 3.6). It has the following options:
−

Button 0: New position: Specifies the new position for the selected point.

−

Button 1: No function

−

Button 2: Change window: Changes the window displayed on the screen.

−

Button 3: Return: Returns to the Point Editor command box.
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Figure 3.6: The Move or Edit Point command box

F
•

Move the cursor about a centimeter above the point 14 and Press
button 0.

If during digitizing points were incorrectly entered, they can be repositioned
afterwards.
Deleting a point

F
•

Choose with the mouse the Select Mode.

•

Put the mouse pointer on point 16 and select it.

•

Press the right mouse button to open the Context-sensitive menu
and select Delete. You can also press the Delete key on the
keyboard.

•

Click Yes in the opened Point Editor message box to confirm.

Multiple points can be selected by pressing the Shift, or the Ctrl key while you
select more points. The digitizing of points is now finished, so you can exit the
Point Editor.

F
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•

Click the Exit button in the button bar.

•

Click the OK button in the opened Display Options - Points dialog
box.

•

Close the map window.
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3.3 Digitizing a segment map
Before you continue with digitizing a segment map, it may be good to explain first
a little about how points, segments and polygons are digitized. Points, segments
and polygons are three types of spatial features used in ILWIS. An individual point
is defined by a pair of X and Y coordinates. A segment is composed of a series of
intermediate points, connected by straight lines, with a starting and ending node. A
polygon is a closed area consisting of one or more segments. All segments forming
a polygon have to be connected at intersections. Each intersection or end
connection of segments has a node (figure 3.7).

Intermediate point
a node

A polygon
a segment

a point

Figure 3.7: Presentation of points, segments and polygons in ILWIS

When you digitize a polygon, the boundary lines of this polygon should be
connected. The connection of one line to another is called snapping. Snapping
always takes place at a node (the end of a line). Snapping is needed for polygons,
and for segment maps that represent a network (e.g. a drainage network, or a road
network). Snapping is not required for other segment maps, such as a contour map.
When you digitize a contour map, you can only snap lines that have equal altitude.
You can digitize a line, by holding down the cursor button and simultaneously
moving the cursor on the line (digitizing in stream mode). The line coordinates are
recorded at regular time intervals. The disadvantage is that many points are needed
to define the segment. Many of these points do not improve the accuracy of the line
and are considered redundant.
You can also digitize a line, by pressing the cursor button only when a point in the
segment needs to be digitized (digitizing in point mode). In this way coordinates
are only recorded if the button is pressed. The number of points used to store a
segment depends on the complexity of the line, and on the accuracy of the person
digitizing.
ILWIS User’s Guide

75

Spatial data input
To reduce the number of coordinates defining a segment, a data reduction
procedure called tunneling is carried out automatically (figure 3.8). The necessity of
each coordinate, is evaluated by connecting the adjacent coordinates by a line or
tunnel with a pre-defined width. When the evaluated coordinate lies inside the
tunnel, it is considered redundant, and is removed. If it lies outside the tunnel, it is
kept and the same operation is carried out for the next coordinate.
phase 1
c
d

phase 2
c
d

b

digitized segment
c
d
b

b

a

a
Tunnel width = 2.5
phase 1

a

b

c

a

phase 2
c

d

d

a
Tunnel width = 3.5

Figure 3.8: The process of tunneling using two different tunnel widths. See text for explanation

In this exercise, a segment map which contains information about the road network
in the area will be created. This segment map is presented in figure 3.9.

F
•

Make a photocopy of figure 3.9.

•

Remove the photocopy of figure 3.3 if it is still on the digitizer.
Position the photocopy of figure 3.9 in the center of your digitizer,
and fasten it to the digitizer with tape. With some digitizers you can
also place the paper under a plastic cover, so that it remains fixed.

•

From the Options menu of the main window, select Digitizer.

•

Choose Map Reference from the sub-menu. The Map Reference
dialog box is opened.

When a new map is placed on the digitizer, or when you have moved the map that
you were digitizing before, you will have to reference the map again. However, the
Map reference dialog box still contains the X and Y values of the control points of
the previous map. So if the new map uses the same control points, the only thing to
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do is to digitize the four points. Once a map is referenced, it remains like that, until
you make a new map reference. So even if you turn off the computer and later on
want to continue digitizing, and the map on the digitizer is still in the same
position, you don’t have to reference your map anymore.

F
•

Accept the defaults by clicking the OK button. The Map
Referencing dialog box (figure 3.4) and MapReferencing
command box (figure 3.4) are opened.

•

Digitize the four control points of figure 3.9. Make sure to digitize
the correct points for the X-Y coordinates that are already given in
the Map Reference dialog box. When the sigma value is around 1
or lower, the error is tolerable. Otherwise digitize the four points
again. Click OK.

•

From the File menu of the main window, select Create and Create
Segment Map. The Create Segment Map dialog box is opened.

•

Type Road in the text box Map Name.

•

Select Cochabam from the list box Coordinate System.

•

Click the Create Domain icon in the list box Domain. The Create
Domain window is opened. Type Road in the text box Domain
Name.

•

Make sure the option Class is selected as the domain type. Click OK.
The Domain Editor is opened.

It is possible to write the names of the domain items in the domain editor directly.
You will, however, create the names during digitizing.

F
•

Close the Domain Editor. You are back in the Create Segment
map dialog box. Click OK. The Display Options- Segment Map
dialog box is opened. Click OK.

The Segment Editor and the Add Segments command box are opened. The
Segment Editor works in Select Mode, Move Points Mode, Split/Merge and
Insert Mode.

Split/Merge Mode: This is only used in the Segment Editor. It allows
the splitting of segments and the creation of a node. It also allows the
removal of unnecessary nodes. When you click this button the mouse
pointer changes to a pair of scissors.
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X=808500
Y=8090500

N

E
U
V Z

K
L
P

F
M
G
H

Q

N
R

O

I
S
T

D

C
J

X=795000
Y=8071500
LEGEND
Segments EF, PQ, HR and RNO
Segments LFN, MGH, HID and ISQ
Segments KLG, CS and TCD
Segments MU, DJ and IR

= highway
= main road
= motorway
= earth road

Figure 3.9: The segment map road (not according to the real situation). The nodes of each line have
a code in this example to facilitate the explanation on how to digitize
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The Add Segment command window shows the position of the digitizer cursor
and the commands. The commands in this window are:
−

Button 0: Begin Segment. Selects the option for digitizing a new segment,
with its starting point not connected to another segment.

−

Button 1: Snap Segment. Selects the option for digitizing a new segment,
with its starting point connected to another segment: snapping.

−

Button 2: Change Window. Changes the window displayed on the screen
(zoom in or zoom out).

−

Button 3: Move Points. Switches the program to the Move Point Mode.

F
•

Move the digitizer cursor away from the part of the digitizer covered
by the map. You will hear a beeping sound. This is to remind you
that the digitizer cursor is outside of the georeferenced area.

•

Move the digitizer cursor back inside the part of the digitizer covered
by the map. The sound stops.

Zooming in
Before you start digitizing a part of the map, we recommend you to zoom in on that
area, so that you can digitize as detailed as possible. This is especially important
when you are going to connect segments.

F
•

Press digitizer button 2 (Change Window). Now the Change
Window command box appears.

•

Position the digitizer cursor on the upper left corner of the box
indicated in figure 3.9 with a hatched line. Press digitizer button 1
(1st Point).

•

Move the digitizer to the opposite corner of the box with a hatched
line and press digitizer button 2 (2nd point). The map window now
only displays the area inside the box. Check this by moving your
digitizer cursor through the box.

Note that you can use button 0 (entire map) to zoom out again.
You can also zoom in by using the mouse pointer. In that case, click the Zoom in
button and define the area you want to zoom in.
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Digitizing segments
In figure 3.9 each node has a code. This is only used here so that we can explain
better how to digitize. To digitize the segment QHISQ:

F
•

Click the Maximize button with the mouse pointer to enlarge the
map window.

•

Position the digitizer cursor at point Q in the map.

•

Press digitizer button 0 to enter the point (starting point of the
segment).

The program proceeds to the command box Digitize Segment (figure 3.10 (a)). In
this box:
−

Button 0: Enter Point. Enters the points of the segment.

−

Button 1: Snap End Segment. Ends a segment by connecting it to another or
by creating a closed segment: Snapping.

−

Button 2: End Segment. Ends the segment, not connected to another
segment.

−

Button 3: Delete Last Point. Deletes wrongly digitized point(s) at the end of
the segment.

(a)

(b)

Figure 3.10: (a) The Digitize Segment command box, (b) the End Segment command box

F

•

Move the digitizer cursor along the line QHISQ while holding down
the button 0 of the digitizer cursor.

Note, since the button 0 is continuously pressed the coordinates are recorded at
regular time intervals (see section 3.2). This is digitizing in stream mode.
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F
•

Release the button 0 when you are just before the starting point (Q) of
the line QHISQ.

It is important to stop digitizing a little bit before you reach the actual point where
you want to connect the segment. This is done to ensure that no additional
intermediate coordinate is digitized, which is in fact on the other side of the
connection point, and which will cause an error when you check the segments later.

F
•

Press button 1 (Snap Segment).

The snap segment ensures that the segment is linked to the starting node. The
program proceeds with the End Segment command box (figure 3.10 (b)). In this
box, you can select:
−

Button 0: Accept. Accepts the point to which the segment will be snapped.

−

Button 1: Snap Other. Selects a node, within the snap tolerance, to be
snapped.

−

Button 2: Snap Split. Splits the selected segment into two and snaps the
segment to the two new segments.

−

Button 3: No Snapping. Returns to the Digitize Segment command box.

F
•

Press the 0 button to snap the last point to the starting point.

The Edit dialog box is opened. In this box you can select one of the existing classes
or New to enter a new name for the digitized segment or for the segment which
will be digitized. In this exercise the domain does not yet contain any class.
Therefore, you have to select New in order to enter a label for the digitized
segment.

F
•

Select New from the list box Value.

The Add Item to Domain dialog box is opened. Here a name, a code and a color
for the digitized segment can be entered. The colors defined here will be used to
display the segments in the map window. It is optional to give codes to segments.
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!

It is advised to enter codes (letters or numbers), especially, when the class
names are long and you intend to use the map for further MapCalc operations.
The codes can be used in the map calculation formula instead of the class
names.

F
•

Type Main road in the text box Name.

•

Type Mr in the text box Code.

•

Select a color in the list box Color. This color will only be shown
after you leave the editor.

•

Click OK in the Add Item to Domain dialog box.

• Click OK in the Edit dialog box.
The lines EF, PQ, HR and RNO represent highways in the map. Before digitizing
the lines, a new class Highway should be added to the domain. To add a new
class:

F
•

From the Edit menu, select Insert Code. The Edit dialog box is
opened.

•

Select New from the list box Value. The Add Item to Domain
dialog box is opened.

•

Type Highway in the text box Name and Hw in the text box Code.

•

Select a color in the list box Color.

•

Click OK in the Add Item to Domain dialog box.

• Click OK in the Edit dialog box.
Now you can also digitize the lines representing highways.

F
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•

Zoom in on the lower part of the map between point E and the lower
right corner of the map.

•

Position the digitizer cursor at point E and press the 0 button.

•

Keep pressing this button and move the cursor along the line EF.

•

Release the button when the cursor is at point F.

•

Press the 2 button (End Segment).

•

Digitize segments KLG and TCD, following the same steps as
described for segments EF.
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Now, if you want to digitize segment CS, there is a problem. Since there is no node
yet at point C, the segment TCD should be split first before you can digitize
segment CS. You can split a segment during digitizing, or by selecting the
Split/Merge mode.

F
•

Click the Split/Merge button. The mouse pointer changes to a pair of
scissors.

•

Position the mouse pointer at point C (check with digitizer cursor)
and click with the mouse. The following message is shown:
Split segment hi: Highway ?

•

Click Yes. The segment is now split and an intermediate node is
shown. Click the newly created node. The message appears:
Merge segment hi: Highway with segment hi: Highway? Click
No.

With the Split/Merge mode you can split segments into two, connected by a node.
You can also use it to remove unnecessary nodes.

F
•

Position the digitizer cursor at point C and press button 1 (snap
segment).

•

Press digitizer button 0 (accept).

•

Press digitizer button 0 and move along the line CS until you are
near to S.

•

Position the mouse pointer on point S and press digitizer button 1
(snap end segment). With a sound it is indicated that the segment
cannot be connected to point C, since there is no node yet. The End
Segment command box appears.

•

Press digitizer button 2 (Snap Split) to split the segment QHISQ.

•

Press digitizer button 0 (Accept) to accept the location where the
segment QHISQ will be split and where the segment CS will be
connected.

The segments KLG, CS, TC and CD are representing Motorways on this map.
Since no new class name has been defined for them yet, they will automatically get
the same class name (Highway) as the last digitized segment: EF. Hence, names
of the segments need to be changed to Motorway.
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F
•

Press the Select Mode button with the mouse pointer.

•

Position the mouse pointer on the segment KLG and select it.

•

Press the Shift key and put the mouse pointer on the segment CS and
select it. This way you can select multiple segments.

•

Do the same for the segments TC and CD. Note that TCD now
consists of two segments, since you have split it.

•

Click the right mouse button, to open the Context-sensitive menu
and select Edit. The Edit dialog box is opened.

•

Select New in the Edit dialog box. The Add Item to Domain dialog
box is opened.

•

Type Motorway in the text box Name. Type Mw in the text box
Code. Select a color in the list box Color and click OK.

•

Click OK in the Edit dialog box.

The names of the segments can also be changed by double-clicking the segment.

F
•

Double-click the segment TC.

•

The list of the existing segment labels is displayed, and you can see
that the selected name for segment TC is motorway.

As you have seen, the connection of one segment to another is done via snapping.
This is to ensure that the segments are linked precisely through the nodes.
Snapping only succeeds if a point exists within the snapping tolerance distance. A
beep warns if this is not the case. Reposition the cursor near the point you want to
snap and try again. The snap command only functions when you snap to the
starting or ending point of a segment. To snap to an intermediate point, the
segment has to be split and then snapped. The snap tolerance is a distance within
which the program will accept a node to snap to it. You can define the snap
tolerance yourself in the Customize Segment Editor dialog box.

F
•

From the File menu of the map window, select Customize. The
Customize Segment Editor dialog box is opened.

Within the Customize Segment Editor dialog box you can see that the default
value for the snap tolerance is 126.666 meters. This means that if you want to
connect two segments, and the cursor is less than 126.666 meters from a node, this
node will be used to connect the two segments. The snap tolerance is defined by the
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system when you start the Segment Editor, based on the coordinate boundaries
(and the scale) of your map. The user may enter another value if needed. A large
value for the snap tolerance will make the map less accurate. A very small value for
the snap tolerance will make the digitizing difficult, since you have to zoom in a lot
before you can snap.
Note also another value in the Customize Segment Editor: The tunnel tolerance.
This value (in this case 12.66) defines the width of corridor between the first and
last of three points (see figure 3.8). If the second point falls within this corridor, it
will not be used as intermediate point, and therefore not stored. If it falls outside of
the corridor, it will be used as intermediate point. So by selecting the tunnel
tolerance you can influence the detail of the lines that you digitize. If you increase
the tunnel tolerance, the segments will be digitized rather coarsely, with only a few
intermediate points. If you make the tunnel tolerance very small, many intermediate
points will be stored and the size of your segment map will become large.
Note also that the default setting for AutoSnap in the Customize Segment
Editor is: Selected. This means that when you end a segment with the mouse, the
system will automatically try to snap it.
Now you will practice some more with snapping segments.

F
•

Click OK in the Customize Segment Editor dialog box.

•

Put the digitizer cursor at point F and press the button 1, to snap the
starting point of the new segment to point F of the segment EF.

•

Digitize segment FL by pressing the button 0. Stop just before L.

•

Press button 1 to snap this segment to point L of segment KLG. The
program proceeds to End Segment command box.

•

Press button 2 to split the segment KLG to segments: KL and LG.

•

Press button 0 to snap the segment FL to one of the segments (KL or
LG).

•

Digitize the rest of the segments, snap or split and snap them where
necessary. To codify the segments, follow the legend of figure 3.9.

Change the position of a point
An incorrectly digitized point can be corrected by re-positioning it afterwards.
Assume that the correct position of point V on the line UM (figure 3.9) is at point
Z. To change the position of this point:

F
•
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Return to the Add Segment command box. Press button 3 to select
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The program proceeds to the Move Points command box. In the Move Points
Mode, all segment nodes appear as little boxes, and all intermediate coordinate
pairs appear as small crosses.
The Move Points Mode can also be selected from the Edit menu or from the
Button bar.
The commands in the Move Points command box (figure 3.11 (a)) are:
−

Button 1: Take Point. Selects the point to be moved.

−

Button 2: Change Window. Changes the window displayed on the screen.

−

Button 3: Return. Return to the Add Segments command box.

F
•

Zoom in on the area surrounding point V.

•

Position the digitizer cursor (box) on the point V and press button 1.

The program proceeds to the Retouch Points command box (figure 3.11 (b)). The
commands in this command box are:
−

Button 0: New Position. Specifies the new position of the selected point.

−

Button 1: Take Point. Selects the point to be moved.

−

Button 2: Snap. Snaps the taken point, to a point on the segment on which it
has been positioned.

−

Button 3: Return. Return to the Move Point command box.

(a)

(b)

Figure 3.11: The Move Points (a) and Retouch point (b) command boxes

F
•

Position the cursor at the new position, point Z and press button 0.

You can also use Move point mode to correctly snap nodes, for example the end
point of segment EF.
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F
•

Zoom in on the area around node F.

•

Put the cursor at node F, and press button 1. The Retouch Points
command box is opened. The line EF is shown in red.

•

Press digitizer button 1 again. Now the segment LF is shown in red
(if it was connected). Press 1 again and the segment FM is shown in
red.

•

Connect it to the other segments by pressing button 2.

Deleting a segment
An incorrectly digitized segment can be deleted. Suppose the segment UM was
incorrectly digitized, and you want to delete it:

F
•

Zoom in on the area of segment UM.

•

Choose with the mouse pointer the Select Mode. Select segment UM.

•

Click with the right mouse button and select Delete from the
Context-sensitive menu.

A deleted segment can be undeleted. If the segment UM was deleted by mistake and
you want to undelete it:

F
•

Open the Context-sensitive menu and select Undelete segments.

•

The deleted segments will be displayed in the map window with a
different color. Selecting the segment MU is enough to undelete it.

Deleted segments are shown in a different color, which can be changed in the
Customize Segment Editor dialog box. If you want to remove the deleted
segments completely, you can select the option Pack from the File menu.

F
•

From the File menu in the map window select Pack.

•

Answer OK, to the question whether you want to pack the data.

Packing the data (removing deleted segments and coordinates), is recommended
before you generate a polygon map from a segment map.
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Displaying segments in different colors
You can quickly see how many classes exist in a segment map, by displaying the
segments in different colors or in the colors defined in a Representation.

F
•

Open the Context-sensitive menu in the map window by clicking
the right mouse button, and select Customize.

The Customize Segment Editor dialog box is opened. From this box you can
choose to display the segments in Normal color, colors defined in the representation
(Domain), or in primary colors.

F
•

Select Domain from this box. Click OK.

•

Click the Exit Editor button. Click OK in the Display Options
dialog box. The segment map is displayed. Close the map window.

The final part of segment digitizing is the checking of the segments. The items that
are checked are intersections of lines without a node, dead ends in segments, self
overlapping segments and consistency of the codes.
The checking of segments is not treated here. In section 3.5 a detailed explanation
will be given of the procedure for checking segments, and correcting errors.
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3.4 Digitizing contour lines
In the previous exercise you have seen how to digitize a segment map with a class
domain. Now you will learn how to digitize segments with a value domain: Contour
lines. Each contour line is digitized with the corresponding height as the value. The
contour value is given in the map (figure 3.12). This contour map can be used to
create a Digital Elevation Model (see chapter 10). Digitizing contour lines is quite
a tedious job. To simplify the exercise, only the southern part the contour map of
the study area will be digitized. When digitizing, take the following into
consideration:
−

Always digitize contour lines a little bit further outside the boundaries of the
study area, to prevent the boundaries of the area having wrong results after
contour interpolation.

−

Where many contour lines are close to each other, it is preferred to digitize
only a few to minimize errors in the interpolation.

−

Hilltops should be digitized as small lines, to prevent the hill having a flat top,
defined by the highest closed contour line.

F
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•

Make a photocopy of figure 3.12.

•

Remove the photocopy of figure 3.9 if it is still on the digitizer.
Position the photocopy of figure 3.12 in the center of your digitizer,
and fasten it to the digitizer.

•

From the Options menu of the main window, select Digitizer.

•

Choose Map Reference from the sub-menu.
The Map Reference dialog box is opened.

•

Reference the map (figure 3.12) to the digitizer, similarly, as
described in section 3.3.
Note that the coordinates of the corners of this map are not the same
as shown in the Map referencing dialog box. You need to change
them. Do not select the X and Y coordinates of the map corners, but
make the minimum X and Y values a bit lower (100 m) and the
maximum ones a bit higher (100 m). This way you can digitize the
contour lines a little bit outside the map boundaries.

•

Double-click New SegMap in the Operations-list.
The Create Segment Map dialog box is opened.

•

Type Isolines for the name of the map.

•

Select Cochabam from the list box Coordinate System.

•

Select the domain Value in the list box Domain.

•

Type 2000 and 4000 in the Range text boxes, and type 0.1 in the
text box Precision.
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•

Click OK.

•

Select the check box Info in the Display Options dialog box and
click OK.

The Segment Editor and the Add Segments command box are opened.

F
•

From the Edit menu of the map window select Insert Code.
The Edit dialog box is opened.

•

Type the value: 2560.

•

Click OK.

•

Digitize the contour lines with the altitude 2560.

•

Press the right mouse button and select Insert Code. Type the value
2580. Digitize the contour lines with this altitude.

•

Digitize all the contour lines.

•

Make sure to snap different parts of the same contour line.

•

Do not digitize the boundary.

When you finish digitizing the contours, you can easily check whether an error was
made, by checking the code consistency. The code consistency check is done to find
segments that are connected, but have different values. This can not be true for
contour lines.

F
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•

From the File menu of the map window, select Check Segments,
and Code Consistency

•

Accept the defaults and click OK.
If the program finds an error, it will indicate the place of the error
with a red box and a dialog box appears stating the nature of the
error: Different codes at node.

•

Correct the errors (if any) by recoding the wrong segments.

•

Press the Exit Editor button when the digitizing is finished.
The Display Options dialog box is opened.

•

Select the check box Info.

•

Select Pseudo representation. Click OK. The map is displayed.

•

Close the map window.
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Figure 3.12: The segment map isolines
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3.5 Creating a polygon map
Now you will see how to digitize a polygon map. A polygon map can be created
using the following steps:
−

Digitizing the boundaries of the polygons as segments in the Segment Editor;

−

Checking the segments in the Segment Editor;

−

Digitizing the labels of the polygons as a point map in the Point Editor;

−

Polygonizing the segments using the point map as labels in the Segment
Editor.

The digitizing of segments is not treated here anymore. This was already explained
in section 3.3. You will start this exercise with a segment map that contains a
number of errors, which will be detected and corrected during the checking of the
segments.
The file with which you will work is called Checkseg. It is the digital version of
figure 3.14. It contains segments with the label Unitbound.

!

If you have already done this exercise before, and want to repeat it, you should
reinstall the data again, since the errors from the segment map are then
removed (for data installation: See ILWIS installation guide).

F
•

Make a photocopy of figure 3.14 and fix this to the digitizer.

•

Reference this map with the method explained in 3.2.

•

Click the segment map Checkseg with the right mouse button and
select Edit from the context-sensitive menu.

•

Click OK in the Display Options dialog box.

The Segment Editor and the Add Segments command box are opened.
Checking segments
After the segments in the map are connected by snapping, you can check whether
this has been done correctly. The most important errors that may occur during
digitizing are shown in figure 3.13:

92

−

Dead end in segment. The segment is not connected to another segment.
This is shown in example 1.

−

Intersection without node. The segment overlays another segment without a
node. Several examples are shown in 2 and 3.
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−

The same segment is digitized twice. This may happen in large files, or in files
you obtain from someone else. This is illustrated in example 4.

−

Self Overlap. The segment crosses itself. This is shown in example 5.

Figure 3.13: Different types of digitizing errors that are detected during the checking of segments.
See text for explanation

Before the map can be polygonized it should be checked whether the segments have
been digitized in an appropriate way. This check is done using the option Check
Segments from the File menu of the Segment Editor map window. It can also be
done when you select the option Polygonize from the File menu.

F
•

From the File menu of the map window, select Check Segment and
Self Overlap. The Check Segments dialog box is opened. Click
OK.

•

The map is now checked for segments that overlap themselves. The
program checks and will give an error message:
Segment unitbound crosses itself. Remove false polygon?

•

Click Cancel. Zoom in on the part where the error occurs, indicated
with a red box. This is near D in the map.

The situation near point D is shown in figure 3.15 (a). As you can see the segment
crosses itself. To correct it automatically, there are two possibilities:
−

Remove the false polygon (shown in figure 3.15 (b)).

−

Split the segment (shown in figure 3.15 (c)).
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Figure 3.14: Polygon map geom
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Figure 3.15: Self overlap error near point D in figure 3.14. A: Original situation showing the overlap.
B: Situation after automatical removal of false polygon. C: Situation after automatic
splitting segments

F
•

From the File menu of the map window, select again Check
Segment and Self Overlap. The Check Segments dialog box is
opened. Click OK.

•

The program will give an error message: Segment unitbound
crosses itself. Remove false polygon? for the same point near D.

•

Click Yes.

•

The program is now checking further on segments that overlap
themselves. It will give again the same error message: Segment
unitbound crosses itself. Remove false polygon? now for a point
near M.

•

Click Cancel. Redraw the map window and zoom in on the part
around point D. Compare the result with figure 3.15 (b). Then zoom
in on the area around M. Check that there is an error.

•

Again select Check Segments, Self Overlap. Click OK. The point
near M with the error is again identified and the message Segment
unitbound crosses itself. Remove false polygon? appears.

•

Click No. Now the message: Split segment unitbound? appears.

•

Click Yes. The program continues checking and will find another
segment overlapping itself. Click Cancel in the error message box.

•

Zoom in on point M and check the result. The situation is comparable
with the one shown in figure 3.15 (c).

It is in general not advisable to use the automatic editing options (such as Remove
false polygon, or Split Segment), since this may lead to many small polygons (if
you use the Split segment option), or to unwanted generalization of the segment
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(if you use the Remove false polygon option). Instead it is often better to edit the
error manually using the Move Point Mode.

F
•

Redraw the map window and zoom in on the area with the red box
(below M).

•

From the File menu in the map window, select Check Segment and
Self Overlap. The Check Segments dialog box is opened.

•

Select the check box Start at Number. The number of the last
checked segment is shown. Click OK. The checking is resumed.

•

The map is now checking further on segments that overlap
themselves. The program checks and will give an error message:
Segment unitbound crosses itself. Remove false polygon? now
again for the point near M.

•

Click No. Now the message: Split segment unitbound? appears.

•

Click No. The editor changes to the Move Points mode and the
place of the error is indicated by a small quadrangle.

•

Zoom in on the lower part of the lake M and use the mouse pointer,
that is now in the form of little tweezers, to move the intermediate
points of the segment, until they no longer overlap. Click the Entire
map button when finished.

•

From the File menu in the map window, select Check Segments
and Self Overlap. The Check Segments dialog box is opened.

•

Select the check box Start at Number. The number of the last
checked segment is shown. Click OK. The checking is resumed and,
if you made the corrections well, no other self overlapping segments
are found.

The next check that will be made is on dead ends in segments (see figure 3.13-1).

F
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•

From the File menu in the map window, select Check Segments
and Dead Ends. The Check Segments dialog box is opened. Click
OK. The map is now checked for segments that are not connected to
others (dead ends). An error message will appear: Dead end in
segment unitbound. The location of the point is indicated by a red
box, in this case close to point A.

•

Click OK and the editor changes to the Move Points mode.

•

Zoom in on the quadrangle near point A in the map. Pick the end of
the segment and move it so that it connects with the other one.

•

Display the entire map.
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•

From the File menu in the map window, select Check Segments
and Dead Ends. The Check Segments dialog box is opened.

•

Select the check box Start at Number. The number of the last
checked segment is shown. Click OK. The checking is resumed.
Again an error will be found, now near point H.

The situation near point H is shown in figure 3.16.

Figure 3.16: Dead ends in segments, near point H in the map of figure 3.14

As you can see there are three segments at point H which are not properly
connected.

F
•

Zoom in on the area around H and use the mouse pointer to move the
nodes of the segments until they connect. Click the Entire map
button when finished.

•

From the File menu of the map window, select Check Segments
and Dead Ends. The Check Segments dialog box is opened.

•

Select the check box Start at Number. The number of the last
checked segment is shown. Click OK. The checking is resumed.
Again an error message will appear, now near point D.

•

Correct the error at point D and resume checking dead ends. There
will be another error at point J. Continue checking dead ends until
no more error messages appear.

The last check that will be made is on intersections without nodes (see figure 3.132 and 3).
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F
•

Display the entire map.

•

From the File menu of the map window, select Check Segments
and Intersections. The Check Segments dialog box is opened.
Click OK. The map is now checked for segments that are intersecting
without a node.

•

An error message will appear: Intersection without node in
segment unitbound. Split segment? in a location near point E.

•

Click No and zoom in on the area around E.

The situation near point E is shown in figure 3.17 (a).

Figure 3.17: Intersection without node near point E in figure 3.14. A: Original situation. B: Situation
after automatic correction

F
•

From the File menu in the map window, select again Check
Segments and Intersections. Click OK.

•

An error message will appear: Intersection without node in
segment unitbound. Split segment? Referring again to a location
near point E. Click Yes. The program resumes checking
intersections and will display an error message for an error near point
L. Don’t accept automatic correction and select No.

The situation near point E after automatic correction is shown in figure 3.17 (b). As
you can see, it is not always advisable to use the automatic editing option since this
may lead to many small polygons. Instead it is often better to edit the error
manually using the Move Point Mode.
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F
•

Display the entire map.

•

Zoom in on the area around L and use the mouse pointer to move the
nodes of the segments so that the two segments no longer intersect.
Click the Entire map button when finished.

•

From the File menu in the map window, select Check Segments
and Intersections. The Check Segments dialog box is opened.
Select the check box Start at Number. The number of the last
checked segment is shown. Click OK. If you corrected the previous
errors well, no more errors are found.

There is one more option to check segments: Code consistency. This is useful only
in situations where you want only segments with the same code to be connected.
For example, in the case of contour lines, where only lines with the same altitude
code should be connected. In the example of the segment map Checkseg this is
not a useful option, since there is only one segment code (Unitbound).
To better see the effect of automatic editing, you will now correct for the small
polygons that were generated during the automatic editing in point M and point E.

F
•

Zoom in on the area around M.

•

Choose the Select Mode, select the small unwanted segments and
delete them by pressing Del.

•

Repeat the same procedure for the area around point E.

The segments of the map Checkseg are now error free, and you can proceed with
the creation of the polygon map.
Creating a label point file
When you create a polygon map, the best procedure is to digitize the boundary lines
of the segments in a segment map, and the labels or names of the polygons as
points in a point map. Now you will digitize a point map, containing the names of
the units in the map of figure 3.14.

F
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•

Double-click New PntMap in the Operations-list in the main
window. The Create Point Map dialog box is opened.

•

Type Landunit in the Map Name text box.

•

Type for the Description: Points indicating the labels
of land unit polygons.
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•

Select the Coordinate system: Checkseg. This is the coordinate
system that was used for the segment map Checkseg. The
coordinate system of the point map should be the same as the one of
the segment map.

•

Click the Create button next to the Domain list box. The Create
Domain dialog box is opened.

•

Type Landunit in the text box Domain Name.

•

Select the option Class. Click OK. The Domain Editor is opened.

•

Press the INS key and add the domain item: Alluvial fan. Click
OK. Add also the domain items: Infilled lake, Lake and
Mountain. Close the Domain Editor. You are now back in the
Create Point Map dialog box.

•

Click OK. The Display Options- Point Map dialog box is opened,
Click OK.

•

The Point Editor and the Point Editor command box are opened
(figure 3.5).

•

Digitize a point within each of the units indicated in figure 3.14. See
exercise 3.2 on how to digitize points.

•

When you are finished digitizing the points, click the Exit Editor
button in the Point Editor. Click OK in the Display Options dialog
box. The point map is displayed.

•

Close the point map.

Creating the polygon map
Now that the segments are checked and you have a label point file, you can proceed
with the polygonization.

F
•

Activate the Segment Editor of the map Checkseg.

•

From the File menu in the map window, select Polygonize. The
Polygonize Segment Map dialog box is opened..

At this point you have the possibility to polygonize the map using a point map with
labels (containing the name of the polygons), to use a domain, or to Auto identify
the polygons (in which default names will be assigned to the polygons).

F
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•

Select the option Label points and select the point map Landunit.

•

Type Landunit for Output polygon Map.
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•

Type: Polygon map of land units for Description. Select
Show and click OK. The segments are checked again and the map is
now polygonized. The Display Options dialog box is opened.

•

Click OK. The polygon map is shown. Click the units to find out
their names.

•

Activate the Segment Editor, displaying the segment map
Checkseg and click the Exit Editor button. Click OK in the
Display Options dialog box. The segment map is shown. Close the
segment map Checkseg. Close also the polygon map Landunit.

The polygon map is now created. The last step is to edit the polygons. In order to be
able to edit it, you should first break the dependency link between the polygon map
Landunit and the segment map Checkseg.

F
•

Click polygon map Landunit with the right mouse button and
select Properties from the Context-sensitive menu. The Properties
dialog box is opened. Click the Break Dependency Link button and
confirm with Yes.

•

Click polygon map Landunit with the right mouse button and
select Edit from the Context-sensitive menu. Click OK in the
Display Options dialog box.

Editing polygons
The Polygon Editor and the Polygon Editor command box are opened. The
Polygon Editor command box only contains two options:
−

Button 0: Edit value: Changing the name of a polygon.

−

Button 1:

−

Button 2: Change window: Changing the window displayed on the screen.

−

Button 2:

F
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•

Zoom in on the area around E and F.

•

Edit the names of the small lake polygons.

•

When finished, press the Exit Editor button. The Display options
dialog box is opened. Click OK.

•

The map Landunit is now ready. Close the map window when
finished.
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If you want to practice some more with the creation of a polygon map, you can
digitize the segment yourself and do the segment check.

F
•

Create a segment map Landun, now using the coordinate system
Cochabam. Digitize the lines of figure 3.14 in a similar way as
explained in exercise 3.3. Digitize all segments, including the
boundaries of the map, and make sure to snap all segments. All
segments in the map may receive the same code: Landun.

•

Check the segments and correct the errors.

•

Create a point map Landun, also using coordinate system
Cochabam, digitize the labels, and use this point map together with
the segment map Landun to create a polygon map Landun.

Summary: Digitizing maps
−

Spatial data in ILWIS are digitized as point, segment or polygon maps.
An individual point is defined by X and Y coordinates.
A segment is composed of a series of intermediate points, connected by
straight lines, with a starting and ending node.
A polygon is a closed area consisting of one or more segments.
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−

Point, segment and polygon maps are digitized and edited with the Point
Editor, Segment Editor and Polygon Editor respectively.

−

The Editors work in Select, Insert and Move Point modes. The Polygon
Editor only has a Select Mode.

−

You can add features to the selection, by clicking them while pressing and
holding the CTRL- key. When you have completed the selection, release the
CTRL- key. To select all points or pixels within a specific area, define a
window enclosing them. This window can be defined by dragging it with the
left mouse button. To deselect any of these features, press and hold the SHIFT
+ CTRL - keys and click on the selected features. When you have finish
deselecting, release the SHIFT + CTRL - keys. To toggle between select and
deselect features, press and hold down the SHIFT key, click the selected one to
be deselected, and non-selected one to be selected. When finished, release the
SHIFT key.

−

Segments are digitized either by continuously digitizing them (stream mode),
or by pressing the digitizer cursor only for some points along the line (point
mode).

−

A data reduction procedure called tunneling is carried out automatically, to
reduce the number of points defining a segment.
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−

In a segment map, generally, it is not needed to connect segments to each
other, except when it concerns linear features that will be used, e.g., in network
analysis.

−

In a polygon map, all segments forming a polygon have to be connected
(snapped) to each other at intersections. In other words, all boundary lines of
polygons should be snapped to each other at their nodes.

−

Segments can be checked for Dead ends (a node that is not connected),
Intersection without node (segment overlays without a node), and Self
Overlap (a segment that crosses itself). For contour maps, it is also useful to
check for Code consistency (check if connected segments have the same
code).

−

Polygon maps are made by first digitizing the boundary lines in the Segment
Editor checking the segments and polygonizing them.

−

A domain type ID, class or value, can be selected for a new map. The domain
of a map is selected, based on the data represented by the map, e.g., a domain
type class for a land use map, value domain for a segment map representing
the contour lines.
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