Chapter 5

Editors
Note: This chapter is written as an enhancement to Chapter 5: Editors in the ILWIS
2.1 Reference Guide. It does not completely replace the mentioned chapter:
instead you are invited to use both as one.

5.1

Representation Class editor

Functionality

With the representation class editor, you can change the representation as used by a
class domain, a group domain, or a picture domain. In the representation class
editor, you see all the class names of the domain to which this representation is
linked and the way in which these classes will be represented on the screen and on a
printer.
For each class as available in the domain, you can edit:
§ colors (for mapping units in raster maps);
§ colors, hatching or patterns (for mapping units in polygon maps);
§ colors, line types, line widths, etc. or use equally spaced symbols (for segments);
§ colors, symbol types, symbol sizes, etc. (for points).
The Representation Class editor consists of an editor window with the class names
and their colors, a menu bar, a button bar, and Red, Green and Blue color slide bars
at the bottom of the window.
To start the Representation Class editor, see How to create a representation and How
to edit a representation.
F

You can always create a number of representations for a certain domain, for
instance by clicking the create button next to the Representation list box in the
Display Options dialog box of a map. Then, to display a map with a certain
representation, in the map's Display Options dialog box, select the representation
you want to use.
General working of the Representation Class editor
1. Select a map type:
–

–
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for Raster,
Click one of the buttons in the button bar:
Polygon, Segment, or Point respectively, or
Open the Options menu and select either Raster, Polygon, Segment or Point.
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Keep in mind that when changing a color of a class in one 'mode' (e.g. Polygon),
then the color of this class will also change for all other modes (e.g. Raster,
Segment).
2. Select a single class in the editor window and subsequently edit the color and
optionally other representation attributes of this class:
–
Double-click a class or its color box in the editor window, or
–
Select a class or its color box and choose Edit Item from the Edit menu, or
–
Select a class or its color box and press the Enter key on the keyboard.
The Edit Repr Item (raster), Edit Repr Item (polygon), Edit Repr Item (segment)
or the Edit Repr Item (point) dialog box will appear.
Depending on whether you selected to edit the raster form, polygon form,
segment form or point form of the representation, the Edit Repr. Item dialog box
will allow you to edit:
–
for raster: colors
–
for polygon: fill colors, hatchings or patterns;
–
for segment: colors, line types (e.g. single, double, triple, dot, dash dot,
blocked), line widths, optional support lines, or a symbol font and a symbol
which will be used to draw lines;
–
for point: simple symbols or symbols from any installed symbol font, symbol
sizes, colors, etc.
Furthermore, you can use the Red, Green and Blue color slide bars at the bottom
of the editor window to edit the colors of a single selected class.
3. Select multiple classes in the editor window and subsequently assign a single
color to all selected classes or assign a smooth range of colors to the selected
classes.
–
Select multiple classes in the editor window by using the Shift and/or Ctrl
key, and
–
Open the Edit menu and choose Edit Multiple Items, or press the Enter key
on the keyboard. The Edit Multiple Items dialog box will appear.
Assigning a range of colors can be used:
–
to obtain smooth color changes between multiple classes, for instance from
yellow to red, through orange, or
–
to obtain similar colors for related classes in a domain, e.g. various forest
types in similar shades of green, etc.
When assigning a color range, the order of the classes in the domain will be
used. For more information, see the Edit Multiple Items dialog box.
To interactively change colors of maps
1. For any raster, polygon, segment or point map with a class or group domain:
–
Display the map in a map window and make sure that the Info check box in
the map's Display Options dialog box is marked;
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–

–
–
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Open the Layers menu in the map window and choose the Double-Click
Action command; in the appearing dialog box, select the Edit Representation
option;
Then, double-click the pixels, polygons, segments or points in the map: each
time a Edit Repr Item dialog box will appear in which you can directly
change colors, polygon patterns, segment line types, line widths, point
symbols, etc.
The map window will directly show the map in the changed representation.
Continue double-clicking units in the map and editing the representation of
that class until satisfied.

2. For any raster, polygon, segment or point map with a class, group or value
domain:
–
Display the map in a map window;
–
Open the Edit menu in the map window and choose the Representation
command;
–
Depending on the type of representation that the domain of this map is using,
the representation class editor as described above, or the representation
value/gradual editor is opened;
–
In the appearing representation editor window, edit one or more colors, etc;
To see the changes in the map window, press the Redraw
button in the
map window;
–
Continue editing colors in the representation editor and redrawing the map
window until satisfied.
In this way, you can work with a representation editor and a map window
simultaneously.
–

F

Advanced users may wish to edit a representation class in table form; click a
representation class with the right mouse button in the Catalog, and choose Open As
Table from the context-sensitive menu.

Button bar

The buttons in the button bar of the Representation Class editor allow you to select a
map type. This shows the representation as if this representation was used by that
map type.
Every class name has a color. Each pixel, polygon, segment, point with that class
name will use that color. Polygons, segments, and points have some other
representation characteristcs as well.
The following actions can be performed:
Raster Map: Edit the colors of this representation as used to display a raster
map.
Polygon Map: Edit the colors, hatchings or patterns of this representation as
used to display a polygon map.
Segment Map: Edit the colors, line types, line widths, etc. of this
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representation as used to display a segment map.
Point Map: Edit the colors, symbols, symbol sizes, etc. of this representation
as used to display a point map.
The button bar can be hidden or shown with the Button Bar command on the
Options menu.

5.2

Georeference Tiepoints editor

Functionality
General information

With the Tiepoint editor you can edit:
§ a georeference tiepoints: to add coordinates to a satellite image or to a scanned
photograph without using a DTM, or
§ a georeference direct linear: to add coordinates to a scanned photograph while
using a DTM, or
§ a georeference orthophoto: to add coordinates to a scanned aerial photograph
while using a DTM and camera parameters.
For more information on georeferences, see ILWIS objects : georeferences.
The Tiepoint editor shows:
§ in a map window: a raster map, for instance a satellite image, a scanned
photograph or a scanned map. This is the background map as specified during
the creation of the georeference. By inserting tiepoints, also called ground
control points, you can establish relationships between the pixels of that map
(row,col) and real world XY- or XYZ-coordinates.
§ existing tiepoints in a table in a secondary window: for each existing tiepoint, its
Row and Column values in the raster map, its real world X- and Y-coordinates,
and the residuals. When editing a georef direct linear or a georef orthophoto,
also Z-values (heights) are shown: column Z_dtm displays height values as
obtained from the Digital Terrain Model (DTM); in case you know more exact
height values for control points, you can enter these yourself in column Z.
The tiepoint editor has a menu bar, a button bar, a status line and a context-sensitive
menu.
Purpose of a georeference tiepoints, direct linear, orthophoto
A georeference tiepoints is mostly used to add coordinates to a satellite image or to
another map, which is not North-oriented and/or in which the pixels do not represent
exactly square areas on the ground. You can also use a georef tiepoints to add
coordinates to a scanned photograph when a DTM of the area is not available. When
working with multi-spectral images, you should add a created georef tiepoints to all
bands of the image by editing the properties of the bands. This type of georeference
can be used to add coordinates to satellite imagery and for subsequent screen
digitizing or to resample the image to another georeference (e.g. to a georef corners)
for overlay operations.
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A georeference direct linear is mostly used to add coordinates to a scanned
photograph which was taken with a normal camera, and when you have a DTM to
also correct for tilt and relief displacement. A georef direct linear performs a Direct
Linear Transformation (DLT). This type of georeference can for instance be used to
add coordinates to small format aerial photographs and for subsequent screen
digitizing or to resample the photograph to another georeference (e.g. to a georef
corners) for overlay operations.
A georeference orthophoto is mostly used to add coordinates to a scanned aerial
photograph with fiducial marks, taken with a photogrammetric camera with known
principal distance, and when you have a DTM to also correct for tilt and relief
displacement. A georef orthophoto performs a Differential rectification. This type of
georeference can be used to add coordinates to professional near vertical aerial
photographs and further monoplotting on the photograph or for creating an
orthophoto (resampling).
When you added tiepoints to an image or a scanned photograph, you can:
§ Display any type of vector data on top of the map;
§ Create or update vector data using the georeferenced image or photo as
background (screen digitizing);
§ Use the map in pixel info;
§ When you have raster maps of different sources or images of different dates and
you want to perform raster operations to combine these maps or images (e.g.
MapCalc, Cross), first create a georeference tiepoints for each set of
maps/images, then use the Resample operation and resample the maps/images
preferably to a georeference corners;
§ When you want to combine rasterized vector maps with satellite data, you can
rasterize the vector data on the georeference tiepoints of the satellite images. In
case you prefer North-oriented raster maps, rasterize the vector maps with a
georeference corners, and Resample the images with the georeference tiepoints
to this georeference corners.
Using the Tiepoint editor

Inserting tiepoints
In the tiepoint editor, tiepoints can be added to a map in several manners:
§ first, click at a recognizable point in the map without coordinates,
§ the Add Tiepoint dialog box appears. In this dialog box, the row and column
values at the position of the click are filled out.
When you already have some tiepoints, the dialog box will also come up with a
suggestion for the XY-coordinates. This suggestion is the result of the
calculation with the existing tiepoints and using the current transformation
method. This suggestion is a measure of the quality of the current tiepoints. The
suggestion is merely a suggestion, it is advised to enter your own XYcoordinates to prevent false accuracy.
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Then:
§ click at the same position in a map which already has correct XY-coordinates
and which is displayed in another map window (Master/Slave), or
§ digitize the same point in an analog paper map on a digitizer, or
§ read the correct XY-coordinates for this point from a table or an analog paper
map, and type these XY-coordinates in the dialog box.
When editing a georef direct linear or a georef orthophoto, you can optionally
specify a Z-value for the inserted tiepoint; otherwise the height value as found in the
DTM is used.
The inserted tiepoint appears in the map window and in the tiepoint table.
For a more detailed description on inserting tiepoints (for instance Master/Slave),
refer to How to use the Georeference Tiepoints editor.
(De)selecting tiepoints
Column Active in the tiepoint table indicates whether or not a tiepoint is used in
the transformation. Include tiepoints by the putting True in column Active;
exclude tiepoints by putting False in column Active. You can type T or F in
column Active or use the space bar to switch between these.
Changing colors and symbol size of tiepoints and/or fiducial marks
To change the colors or symbol size of tiepoints or to change the colors of fiducial
marks, choose Customize from the Edit menu.
Deleting tiepoints
To delete a tiepoint, choose Delete Tiepoint from the Edit menu, or click the Delete
Tiepoint button in the button bar. Furthermore, after selecting a tiepoint in the
tiepoint table, you can press Del on the keyboard, or use the right mouse button and
select Delete from the context-sensitive menu.
Georef Tiepoints transformation method
When editing a georef tiepoints, one of the following transformation methods can be
selected: conformal, affine, second order bilinear, full second order, third order and
projective.
§ For satellite images an affine transformation will usually do;
§ For a scanned photograph (without DTM), a projective transformation is
recommended.
Tiepoint requirements
§ Mathematical minimum number of tiepoints required:
–
Georef tiepoints: conformal 2; affine 3; second order 4; full second order 6;
third order 10; projective 4.
–
Georef direct linear: 6
–
Georef orthophoto: 3
§ You should always insert more tiepoints than is mathematically required.
§ Tiepoints should be well spread over the map (XY-direction).
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§ For a georef direct linear, the tiepoints should also be well spread in Z-direction
and they should not be co-planar, i.e. in Z-direction, the tiepoints should not be
on a (tilted) plane.
Inspecting DRow, DCol and Sigma
Columns DRow and DCol show the difference between calculated Row and Col
values and actual Row and Col values in pixels. Very good control points have
DRow and DCol values less than 2. Sigma is calculated from these values and the
degrees of freedom, and gives a measure for the overall accountability or credibility
of the active tiepoints.
F

F

F

F

When you have already a vector map of the area of the image, it can be handy to
display this vector map on top of the image while working with the tiepoint editor.
When you now add tiepoints to the image and press the Redraw button
, you
can judge the quality of the tiepoints.
For a georef tiepoints which should be used by all bands of a satellite image: after
you have finished adding tiepoints to a background map in the Tiepoint editor, you
have to add the created georef tiepoints to all bands of the image. This can be done
by opening the Properties dialog boxes of the bands, click the Edit Properties button
and select the correct georef tiepoints.
When finished creating a georeference for an image or a photograph, you can
directly create a segment map (choose File, Create in the map window) and start
screen digitizing on the image or photo which now uses the created georef tiepoints,
georef direct linear or georef orthophoto. When you created a georef orthophoto, the
screen digitizing is called monoplotting.
When finished editing a georef tiepoints, a georef direct linear or a georef
orthophoto, detailed information on transformation or orientation results can be
viewed in the Properties dialog box of the georeference: click the Additional Info
button.

Button bar

The button bar of the georeference tiepoints editor largely resembles the button bar
of a map window but there are some extra buttons to add a tiepoint, to delete a
tiepoint, to choose a transformation method and to exit the editor.
The following actions can be performed:
Entire Map: Displays the entire map in the map window.
Zoom In: Zooms in on a selected spot or area in the map. The mouse
pointer changes into a magnifying-glass. Click to zoom in on a spot of
interest, or drag the pointer from one corner of interest to another (the
mouse pointer changes into a little box).
Zoom Out: Zooms out directly from the center of the displayed map with
a factor 2.
Larger: Enlarges the size of the window with a factor 2. If this would not
fit on your screen, this button is empty.
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Smaller: Reduces the size of the window with a factor 2.
Redraw: Redraws the contents of the map window.
Add tiepoint: Opens the Add Tiepoint dialog box in which you can enter
Row and Column numbers and XY-coordinates for a new tiepoint from
the keyboard. You can also add tiepoints by clicking in the map window,
or by typing the Row and Column numbers and XY-coordinates directly
in the tiepoint table.
Delete tiepoint: Opens the Delete Tiepoint dialog box in which you can
specify the the number of the tiepoint you want to delete. You can also
delete one or more tiepoints by selecting records in the tiepoint table, then
press the Del key on the keyboard or choose Delete from the Edit menu.
Transformation method: Opens the Transformation dialog box in which
you can select a transformation method with which the relation between
Row and Column values and the XY-coordinates of your tiepoints should
be calculated. This button is only available when editing a georef
tiepoints.
Exit editor: Leaves the editor and keeps all changes.
The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.

5.3

Coordinate system Tiepoints editor

Functionality
General information

With the Coordinate system Tiepoints editor you can edit a coordinate system
tiepoints: to add coordinates to a vector map. For more information on coordinate
systems, see ILWIS objects : coordinate systems.
The Coordinate system Tiepoints editor shows:
§ in a map window: one or more vector maps. This is the background map as
specified during the creation of the coordinate system. By inserting tiepoints,
you can establish relationships between the current XY-coordinates in the map
and related XY-coordinates.
§ existing tiepoints in a table in a secondary window: for each existing tiepoint, its
current XY-coordinate (X and Y) in the vector maps, its related XY-coordinates
(RelX and RelY), and the residuals (DX and DY).
The coordinate system tiepoints editor has a menu bar, a button bar, a status line and
a context-sensitive menu.
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Purpose of a coordinate system tiepoints
A coordinate system tiepoints is mostly used to add correct XY-coordinates to a
vector map which has wrong or artificial coordinates, e.g. maps starting at (0,0),
maps digitized in millimeters, or maps that were were imported from other packages
and do not have correct coordinates.
When working with multiple imported vector maps of the same kind, you should
add a created coordsys tiepoints to all similar vector maps, by editing the properties
of these maps.
When you added a coordsys tiepoints to a vector map, you can:
§ Display the vector map on top of any map with correct coordinates;
§ Use the map and the coordinate system in Pixel Info;
§ To actually change the XY-coordinates of your vector maps, first create a
coordinate system tiepoints, then transform the vector maps to the correct
coordinate system.
Using the Coordinate system Tiepoint editor

Inserting tiepoints
In the tiepoint editor, tiepoints can be added to a map in several manners:
§ first, click at a recognizable point in the map with wrong coordinates,
§ the Add Tiepoint dialog box appears. In this dialog box, the current XYcoordinates at the position of the click are filled out.
When you already have some tiepoints, the dialog box will also come up with a
suggestion for the related XY-coordinates. This suggestion is the result of the
calculation with the existing tiepoints and using the current transformation
method. This suggestion is a measure of the quality of the current tiepoints. The
suggestion is merely a suggestion, it is advised to enter your own related XYcoordinates to prevent false accuracy.
Then:
§ click at the same position in a map which already has correct XY-coordinates
and which is displayed in another map window (Master/Slave), or
§ digitize the same point in an analog paper map on a digitizer, or
§ read the correct XY-coordinates for this point from a table or an analog paper
map, and type these XY-coordinates in the dialog box.
The inserted tiepoint appears in the map window and in the tiepoint table.
(De)selecting tiepoints
Column Active in the tiepoint table indicates whether or not a tiepoint is used in
the transformation. Include tiepoints by the putting True in column Active; exclude
tiepoints by putting False in column Active. You can type T or F in column
Active or use the space bar to switch between these.
Changing colors and symbol size of tiepoints:
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To change the colors or symbol size of tiepoints or to change the colors of fiducial
marks, choose Customize from the Edit menu.
Deleting tiepoints
To delete a tiepoint, choose Delete Tiepoint from the Edit menu, or click the Delete
Tiepoint button in the button bar. Furthermore, after selecting a tiepoint in the
tiepoint table, you can press Del on the keyboard, or use the right mouse button and
select Delete from the context-sensitive menu.
Coordsys Tiepoints transformation method
When editing a coordinate system tiepoints, one of the following transformation
methods can be selected: conformal, affine, second order bilinear, full second order,
third order and projective. An affine transformation will usually do.
Changing the boundaries of the coordinate system
When creating a coordinate system tiepoints in a map window, then for the
boundaries of the new coordsys tiepoints, the boundaries of the map window are
automatically used. Usually, you will not have to change these values.
Tiepoint requirements
§ Mathematical minimum number of tiepoints required: conformal 2; affine 3;
second order 4; full second order 6; third order 10; projective 4.
§ You should always insert more tiepoints than is mathematically required.
§ Tiepoints should be well spread over the map (XY-direction).
Inspecting DX, DY and Sigma
Columns DX and DY show the difference between calculated related XYcoordinates and actual XY-coordinates in meters. Sigma is calculated from these
values and the degrees of freedom, and gives a measure for the overall
accountability or credibility of the active tiepoints.

Menu commands
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File

Exit Editor

Edit

Copy
Paste
Delete
Add Tiepoint ...
Delete Tiepoint ...
Transformation ...
Boundaries ...
Customize ...

Layers
Options

see map window
see map window
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Context sensitive menu
Select Area
Add Tiepoint
Delete Tiepoint
Transformation
Customize
Exit Editor

Button bar

The button bar of the coordinate system tiepoints editor largely resembles the button
bar of a map window but there are some extra buttons to add a tiepoint, to delete a
tiepoint, to choose a transformation method and to exit the editor.
The following actions can be performed:
Entire Map: Displays the entire map in the map window.
Zoom In: Zooms in on a selected spot or area in the map. The mouse
pointer changes into a magnifying-glass. Click to zoom in on a spot of
interest, or drag the pointer from one corner of interest to another (the
mouse pointer changes into a little box).
Zoom Out: Zooms out directly from the center of the displayed map with
a factor 2.
Larger: Enlarges the size of the window with a factor 2. If this would not
fit on your screen, this button is empty.
Smaller: Reduces the size of the window with a factor 2.
Redraw: Redraws the contents of the map window.
Add tiepoint: Opens the Add Tiepoint dialog box in which you can enter
Row and Column numbers and XY-coordinates for a new tiepoint from
the keyboard. You can also add tiepoints by clicking in the map window,
or by typing the Row and Column numbers and XY-coordinates directly
in the tiepoint table.
Delete tiepoint: Opens the Delete Tiepoint dialog box in which you can
specify the the number of the tiepoint you want to delete. You can also
delete one or more tiepoints by selecting records in the tiepoint table, then
press the Del key on the keyboard or choose Delete from the Edit menu.
Transformation method: Opens the Transformation dialog box in which
you can select a transformation method with which the relation between
Row and Column values and the XY-coordinates of your tiepoints should
be calculated. This button is only available when editing a georef
tiepoints.
Exit editor: Leaves the editor and keeps all changes.
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The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.

5.4

Annotation Text editor

Functionality

The Annotation Text editor allows you to edit text items stored in an Annotation
Text object.
With the Annotation Text editor, you can:
§ insert new texts and delete selected existing texts,
§ move one or more selected texts to another position,
§ make text duplicates, and
§ specify fonts, sizes, colors, etc. for (multiple) selected texts.
Additionally, you can cut, copy and paste text items to and from the clipboard, and
change the working scale.
The Annotation Text editor has a menu bar, a context-sensitive menu, and a button
bar. All changes that you make in the annotation text object are continuously stored.
You can also edit an annotation text object in table form. This may provide quicker,
easier or more precise possibilities to edit texts, positions and other settings like
font, font sizes, colors, etc. To open an annotation text object as a table, you can
double-click the object in the Catalog, or open the File menu in the Main window,
choose Open As Table and select an annotation text object.
F

While annotation text is edited in the Annotation Text editor, other annotation types
like single texts, legends, boxes, North arrows, scale bars, grid lines, graticule,
bitmaps or metafiles are edited with the Annotation editor.
To start the Annotation Text editor
The Annotation Text editor is automatically started when you create a new
annotation text object. For more information, see the Create Annotation Text dialog
box.
To edit an annotation text object, which is displayed in a map window, open the Edit
menu, choose Edit Layer and select the annotation text layer. For more information,
see ILWIS objects : annotation text objects.
To insert more annotation text items
In the Create Annotation Text dialog box, you will usually base a new annotation
text object on an existing polygon, segment or point map. You will then
automatically obtain texts (class names, IDs, or values) of all polygons, segments or
points in that map.

88

ILWIS 2.2 Guide

Annotation Text editor

Editors

To add more or other text items
§ double-click at a new position in the editor window;
§ locate the mouse pointer at a position where you want to insert a new text and
press the Ins key on the keyboard;
§ open the Edit menu and choose the Add Text command;
§ press the right mouse button and select Add Text from the context-sensitive
menu.
The Add Text / Edit Text dialog box will appear. When you use the Edit menu or the
context-sensitive menu, you may have to position the text later on.
To change the text string, font, font size, colors, etc, of text items
To change text and settings of a single text:
§ double-click a single text item;
§ select a single text item, press the right mouse button and choose Edit from the
context-sensitive menu;
§ select a single text item, and press the Enter key.
The Add Text / Edit Text dialog box will appear in which you can edit the existing
text, the font in which this text item appears, the font size, the color, etc.
To change settings of multiple selected texts:
§ select multiple text items, press the right mouse button and choose Edit from the
context-sensitive menu;
§ select multiple text items, and press the Enter key.
The Edit Texts dialog box will appear in which you can edit the the font in which all
these text items appear, the font size, the color, etc.
To change only one setting for one or more selected text items: choose the Change
command from the Edit menu or from the context-sensitive menu. You can either
change the font, the font size, whether the selected text(s) appear in bold, italics or
underlined (toggles), the color, the justification, whether rectangles around the text
should be transparent (toggle) and the rotation. For font, font size, color, justification
and rotation, a little dialog box will appear; the other settings are toggles without
dialog box.
To change only one setting for one or more selected text items, you can also use the
following short cut keys on the keyboard:
Shift + F
to select another font;
Shift + S
to change the font size;
Shift + B
toggle between bold / not bold;
Shift + I
toggle between italics / not italics;
Shift + U
toggle between underlined / not underlined;
Shift + C
to select another color;
Shift + J
to select another justification method;
Shift + T
toggle between transparent / not transparent;
Shift + R
to select another rotation.
To select multiple text items
§ open the Edit menu and choose Select All: all text items will be selected, or
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§ drag a box around the text items which you want to select, or
§ press and hold the Shift key down and click the text items which you want to
select.
To position annotation text items
§ click on a single text item and drag it to another position;
§ double-click a single text item and fill out XY-coordinate or RowCol numbers in
the Add Text / Edit Text dialog box, or
§ select multiple text items and drag them to another position.
To cut, copy and paste selected text items
Select one or more text items, and:
§ press Ctrl+X (cut) to remove the selected items from the editor window and
copy them into the clipboard;
§ press Ctrl+C (copy) to copy the selected items to the clipboard;
§ press Ctrl+V (paste) to paste the contents (first line) of the clipboard into the
editor window, at the current position of the mouse pointer.
You can also use the Cut, Copy and Paste commands on the Edit menu or on the
context-sensitive menu.
To make duplicates of annotation text items
§ Select one or more text items,
§ press and hold the Ctrl key down, then
§ press and hold the left mouse button down, and
§ move the mouse pointer to another position.
To delete annotation text items
Select one or more text items, and:
§ press the Del key on the keyboard;
§ select Delete from the Edit menu or from the context-sensitive menu.
To change the working scale
You can change the working scale, which determines the relation between font sizes
on your screen and on the printer. The working scale is usually the scale on which
you want to print your maps later on. To change the working scale: open the File
menu and choose Options. The Options dialog box will appear in which you can
specify another value for your working scale.
Subsequently, a question will be asked: Update all font sizes?
§ answer Yes if you want to keep your texts in the same proportions;
§ answer No if you want to keep the font sizes as specified before; then, if you
Redraw the editor window, the texts may appear larger or smaller depending on
whether you specified a larger or smaller value for the working scale.
To exit the Annotation Text editor
§ double-click the Control-menu box, or
§ in the button bar, click the Exit Editor button , or
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§ from the File menu, choose Exit Editor.
All changes that you make in the annotation text object are continuously stored.
Menu commands
File

Options
Exit Editor

Edit

Cut
Copy
Paste
Delete
Select All
Add Text ...
Edit ...
Change

Layers
Options

font
font size
bold
italic
underline
color
justification
transparency
rotation.

see pixel editor
see pixel editor

Button bar

The button bar of the annotation text editor largely resembles the button bar of a
map window; there is an extra button to exit the editor.
The following actions can be performed:
Entire Map: Displays the entire map in the map window.
Zoom In: Zooms in on a selected spot or area in the map. The mouse
pointer changes into a magnifying-glass. Click to zoom in on a spot of
interest, or drag the pointer from one corner of interest to another (the
mouse pointer changes into a little box).
Zoom Out: Zooms out directly from the center of the displayed map with
a factor 2.
Larger: Enlarges the size of the window with a factor 2. If this would not
fit on your screen, this button is empty.
Smaller: Reduces the size of the window with a factor 2.
Redraw: Redraws the contents of the annotation text editor.
Exit editor: Leaves the annotation text editor and keeps all changes.
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Editors

Annotation Text editor
The button bar can be hidden or shown with the Button Bar command on Options
menu. If the action of a certain button cannot be performed at a certain moment, the
button appears gray.
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